$re = '/^(?:https?:\/\/(?:www\.)?|https:(?:\/\/)?)?\w+(?:[-.]\w+)+(?:\/[^\/\s]+)*$/mi';
$str = 'So based on the criteria, these should pass:
http://www.google.com
google.com
abc.def.ghi/hij
https:216.239.38.120
216.239.38.120
These should not pass:
hello
hello/world
abc://def.ghi
ftp:google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);