using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?:\\{2})*(?:""[^""\\]*(?:\\.[^""\\]*)*""|'[^'\\]*(?:\\.[^'\\]*)*')(*SKIP)(?!)|\s+";
string substitution = @"";
string input = @"abc | xx ?? ""1 x ' 3"" d e f ' y "" 5 ' x yz";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}