use strict;
my $str = 'abc | xx ?? "1 x \' 3" d e f \' y " 5 \' x yz';
my $regex = qr/(?<!\\)(?:\\{2})*(?:"[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')(*SKIP)(?!)|\s+/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";