$re = '/(?<!\\\\)(?:\\\\{2})*(?:"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\')(*SKIP)(?!)|\s+/s';
$str = 'abc | xx ?? "1 x \' 3" d e f \' y " 5 \' x yz';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;