const regex = /(?<!\\)(?:\\{2})*(?:"[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')(*SKIP)(?!)|\s+/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)(?:\\\\{2})*(?:"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\')(*SKIP)(?!)|\\s+', 'gs')
const str = `abc | xx ?? "1 x ' 3" d e f ' y " 5 ' x yz`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);