re = /(?<!\\)(?:\\{2})*(?:"[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')(*SKIP)(?!)|\s+/
str = 'abc | xx ?? "1 x \' 3" d e f \' y " 5 \' x yz'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result