#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)@\[[^\][]*]\(([^()]*)\)"
Local $sString = "Today is going to be @[City Temp](city-temp) in @[City Name](city-name)"
Local $sSubst = "{{$1}}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)