use strict;
my $str = 'Today is going to be @[City Temp](city-temp) in @[City Name](city-name)';
my $regex = qr/@\[[^\][]*]\(([^()]*)\)/mp;
my $subst = '{{$1}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";