package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@\[[^\][]*]\(([^()]*)\)`)
var str = `Today is going to be @[City Temp](city-temp) in @[City Name](city-name)`
var substitution = "{{$1}}"
fmt.Println(re.ReplaceAllString(str, substitution))
}