using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\[[^\][]*]\(([^()]*)\)";
string substitution = @"{{$1}}";
string input = @"Today is going to be @[City Temp](city-temp) in @[City Name](city-name)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}