$re = '/@\[[^\][]*]\(([^()]*)\)/m';
$str = 'Today is going to be @[City Temp](city-temp) in @[City Name](city-name)';
$subst = "{{$1}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;