#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(a\+b\)(?:\(ab\+ba\))*$"
Local $sString = "(a+b)" & @CRLF & _
"(a+b)(ab+ba)" & @CRLF & _
"(a+b)(ab+ba)(ab+ba)" & @CRLF & _
"(ab+ba)" & @CRLF & _
"a+b" & @CRLF & _
" (a+b)(, (a+b)a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")