import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(a\\+b\\)(?:\\(ab\\+ba\\))*$";
final String string = "(a+b)\n"
+ "(a+b)(ab+ba)\n"
+ "(a+b)(ab+ba)(ab+ba)\n"
+ "(ab+ba)\n"
+ "a+b\n"
+ " (a+b)(, (a+b)a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}