using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(a\+b\)(?:\(ab\+ba\))*$";
string input = @"(a+b)
(a+b)(ab+ba)
(a+b)(ab+ba)(ab+ba)
(ab+ba)
a+b
(a+b)(, (a+b)a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}