package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(a\+b\)(?:\(ab\+ba\))*$`)
var str = `(a+b)
(a+b)(ab+ba)
(a+b)(ab+ba)(ab+ba)
(ab+ba)
a+b
(a+b)(, (a+b)a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}