$re = '/^\(a\+b\)(?:\(ab\+ba\))*$/m';
$str = '(a+b)
(a+b)(ab+ba)
(a+b)(ab+ba)(ab+ba)
(ab+ba)
a+b
(a+b)(, (a+b)a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);