package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B@\w+\('[\w+\s]+',\s+
(?(?='(?=(\w+\)|\w+\()))
'[\w\)\(]+'
|('\w+'|\$\w+)
)\)`)
var str = `@extends('template', 'te)st')
@extends('template', 'te())st')
@extends('template', 'te()st')
@extends('template', 'test')
@extends('template', 'te(st')
@extends('template', $test)
@extends('template', test)
@extends('template', 'test)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}