// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\B@\w+\('[\w+\s]+',\s+
(?(?='(?=(\w+\)|\w+\()))
'[\w\)\(]+'
|('\w+'|\$\w+)
)\)").unwrap();
let string = "@extends('template', 'te)st')
@extends('template', 'te())st')
@extends('template', 'te()st')
@extends('template', 'test')
@extends('template', 'te(st')
@extends('template', $test)
@extends('template', test)
@extends('template', 'test)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}