import Foundation
let pattern = #"""
\B@\w+\('[\w+\s]+',\s+
(?(?='(?=(\w+\)|\w+\()))
'[\w\)\(]+'
|('\w+'|\$\w+)
)\)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
@extends('template', 'te)st')
@extends('template', 'te())st')
@extends('template', 'te()st')
@extends('template', 'test')
@extends('template', 'te(st')
@extends('template', $test)
@extends('template', test)
@extends('template', 'test)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)