re = /\B@\w+\('[\w+\s]+',\s+
(?(?='(?=(\w+\)|\w+\()))
'[\w\)\(]+'
|('\w+'|\$\w+)
)\)/x
str = '@extends(\'template\', \'te)st\')
@extends(\'template\', \'te())st\')
@extends(\'template\', \'te()st\')
@extends(\'template\', \'test\')
@extends(\'template\', \'te(st\')
@extends(\'template\', $test)
@extends(\'template\', test)
@extends(\'template\', \'test)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end