import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B@\\w+\\('[\\w+\\s]+',\\s+\n"
+ "(?(?='(?=(\\w+\\)|\\w+\\()))\n"
+ "'[\\w\\)\\(]+'\n"
+ "|('\\w+'|\\$\\w+)\n"
+ ")\\)";
final String string = "@extends('template', 'te)st') \n"
+ "@extends('template', 'te())st')\n"
+ "@extends('template', 'te()st') \n"
+ "@extends('template', 'test')\n"
+ "@extends('template', 'te(st')\n"
+ "@extends('template', $test)\n"
+ "@extends('template', test)\n"
+ "@extends('template', 'test)";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}