using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|^(?=.*STRING99)|^.*(*ACCEPT))\d*\K[^\d\n]+";
string substitution = @"";
string input = @"a1 STRING99 2b c3d
a1 2b c3d";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}