# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\G(?!^)|^(?=.*STRING99)|^.*(*ACCEPT))\d*\K[^\d\n]+"
test_str = ("a1 STRING99 2b c3d\n"
"a1 2b c3d")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.