$re = '/(?:\G(?!^)|^(?=.*STRING99)|^.*(*ACCEPT))\d*\K[^\d\n]+/m';
$str = 'a1 STRING99 2b c3d
a1 2b c3d';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;