const regex = /(?:\G(?!^)|^(?=.*STRING99)|^.*(*ACCEPT))\d*\K[^\d\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|^(?=.*STRING99)|^.*(*ACCEPT))\\d*\\K[^\\d\\n]+', 'gm')
const str = `a1 STRING99 2b c3d
a1 2b c3d`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);