use strict;
my $str = 'a1 STRING99 2b c3d
a1 2b c3d';
my $regex = qr/(?:\G(?!^)|^(?=.*STRING99)|^.*(*ACCEPT))\d*\K[^\d\n]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";