#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=<center><b><br>)(.*)(?=<\/b><\/center>)"
Local $sString = "//EXAMPLE 1" & @CRLF & _
"<center>DB Results:</center><center><b><br>ripster.ultima</b></center><center><b><br>raghav.jhavar</b></center></center></td></tr></table>" & @CRLF & _
"" & @CRLF & _
"//EXAMPLE 2" & @CRLF & _
"<center>DB Results:</center><center><b><br>ripster.ultima</b></center>" & @CRLF & _
"<center><b><br>raghav.jhavar</b></center></center></td></tr></table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")