use strict;
my $str = '//EXAMPLE 1
<center>DB Results:</center><center><b><br>ripster.ultima</b></center><center><b><br>raghav.jhavar</b></center></center></td></tr></table>
//EXAMPLE 2
<center>DB Results:</center><center><b><br>ripster.ultima</b></center>
<center><b><br>raghav.jhavar</b></center></center></td></tr></table>';
my $regex = qr/(?<=<center><b><br>)(.*)(?=<\/b><\/center>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}