$re = '/(?<=<center><b><br>)(.*)(?=<\/b><\/center>)/m';
$str = '//EXAMPLE 1
<center>DB Results:</center><center><b><br>ripster.ultima</b></center><center><b><br>raghav.jhavar</b></center></center></td></tr></table>
//EXAMPLE 2
<center>DB Results:</center><center><b><br>ripster.ultima</b></center>
<center><b><br>raghav.jhavar</b></center></center></td></tr></table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);