const regex = /(?<=<center><b><br>)(.*)(?=<\/b><\/center>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<center><b><br>)(.*)(?=<\\\/b><\\\/center>)', 'gm')
const str = `//EXAMPLE 1
<center>DB Results:</center><center><b><br>ripster.ultima</b></center><center><b><br>raghav.jhavar</b></center></center></td></tr></table>
//EXAMPLE 2
<center>DB Results:</center><center><b><br>ripster.ultima</b></center>
<center><b><br>raghav.jhavar</b></center></center></td></tr></table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}