re = /(?<=<center><b><br>)(.*)(?=<\/b><\/center>)/m
str = '//EXAMPLE 1
<center>DB Results:</center><center><b><br>ripster.ultima</b></center><center><b><br>raghav.jhavar</b></center></center></td></tr></table>
//EXAMPLE 2
<center>DB Results:</center><center><b><br>ripster.ultima</b></center>
<center><b><br>raghav.jhavar</b></center></center></td></tr></table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end