#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=http://example\.com/)(fr/|de/|eng/)?.*(?=document_title\d\.php)"
Local $sString = "http://example.com/a/v/c/document_title1.php" & @CRLF & _
"http://example.com/fr/x/1/o/document_title2.php" & @CRLF & _
"http://example.com/de/a/a/2/document_title3.php" & @CRLF & _
"http://example.com/eng/6/z/z/document_title4.php"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)