# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=http://example\.com/)(fr/|de/|eng/)?.*(?=document_title\d\.php)"
test_str = ("http://example.com/a/v/c/document_title1.php\n"
"http://example.com/fr/x/1/o/document_title2.php\n"
"http://example.com/de/a/a/2/document_title3.php\n"
"http://example.com/eng/6/z/z/document_title4.php")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.