import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=http://example\\.com/)(fr/|de/|eng/)?.*(?=document_title\\d\\.php)";
final String string = "http://example.com/a/v/c/document_title1.php\n"
+ "http://example.com/fr/x/1/o/document_title2.php\n"
+ "http://example.com/de/a/a/2/document_title3.php\n"
+ "http://example.com/eng/6/z/z/document_title4.php";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}