const regex = new RegExp('(?<=http://example\\.com/)(fr/|de/|eng/)?.*(?=document_title\\d\\.php)', 'gm')
const str = `http://example.com/a/v/c/document_title1.php
http://example.com/fr/x/1/o/document_title2.php
http://example.com/de/a/a/2/document_title3.php
http://example.com/eng/6/z/z/document_title4.php`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);