using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([0-F]+)\b";
string substitution = @"0$1~0123456789ABCDEF0";
string input = @"109";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}