import Foundation
let pattern = #"\b([0-F]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"109"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1~0123456789ABCDEF0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)