$re = '/\b([0-F]+)\b/';
$str = '109';
$subst = "0$1~0123456789ABCDEF0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;