#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)4(\.|,)*(b|!|8)*\.?\s*[0-9\.]*"
Local $sString = "OCR: B VOZAGKA DOZVOLA REPURLKAHRWISGA )" & @CRLF & _
"HR 1. UZORAK" & @CRLF & _
"2. SPECIMEN" & @CRLF & _
"3. 01011977" & @CRLF & _
"1 42.01.07.2013 4. PUDUBROVACKO - NERETVANSKA" & @CRLF & _
"e 4b. 01.07.2023" & @CRLF & _
"5. 1234587 S i" & @CRLF & _
", E %I\\'\f Dt — |" & @CRLF & _
": = L 9.8 =" & @CRLF & _
"D112345671234567890121012017<2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")