import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"4(\.|,)*(b|!|8)*\.?\s*[0-9\.]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
OCR: B VOZAGKA DOZVOLA REPURLKAHRWISGA )
HR 1. UZORAK
2. SPECIMEN
3. 01011977
1 42.01.07.2013 4. PUDUBROVACKO - NERETVANSKA
e 4b. 01.07.2023
5. 1234587 S i
, E %I\\'\f Dt — |
: = L 9.8 =
D112345671234567890121012017<2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}