// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)4(\.|,)*(b|!|8)*\.?\s*[0-9\.]*").unwrap();
let string = "OCR: B VOZAGKA DOZVOLA REPURLKAHRWISGA )
HR 1. UZORAK
2. SPECIMEN
3. 01011977
1 42.01.07.2013 4. PUDUBROVACKO - NERETVANSKA
e 4b. 01.07.2023
5. 1234587 S i
, E %I\\\\'\\f Dt — |
: = L 9.8 =
D112345671234567890121012017<2";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}