$re = '/4(\.|,)*(b|!|8)*\.?\s*[0-9\.]*/u';
$str = 'OCR: B VOZAGKA DOZVOLA REPURLKAHRWISGA )
HR 1. UZORAK
2. SPECIMEN
3. 01011977
1 42.01.07.2013 4. PUDUBROVACKO - NERETVANSKA
e 4b. 01.07.2023
5. 1234587 S i
, E %I\\\\\'\\f Dt — |
: = L 9.8 =
D112345671234567890121012017<2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);