#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)(\d{6})(?!\d)"
Local $sString = "teste 1 n°123456 fim do teste" & @CRLF & _
"teste 2 n°7890123 fim do teste" & @CRLF & _
"132567" & @CRLF & _
"texto com numero no fim123456" & @CRLF & _
"texto222333texto" & @CRLF & _
"texto2223334texto"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")