import re
regex = re.compile(r"(?<!\d)(\d{6})(?!\d)", flags=re.MULTILINE)
test_str = ("teste 1 n°123456 fim do teste\n"
"teste 2 n°7890123 fim do teste\n"
"132567\n"
"texto com numero no fim123456\n"
"texto222333texto\n"
"texto2223334texto")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")