$re = '/(?<!\d)(\d{6})(?!\d)/m';
$str = 'teste 1 n°123456 fim do teste
teste 2 n°7890123 fim do teste
132567
texto com numero no fim123456
texto222333texto
texto2223334texto';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);