const regex = /(?<!\d)(\d{6})(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)(\\d{6})(?!\\d)', 'gm')
const str = `teste 1 n°123456 fim do teste
teste 2 n°7890123 fim do teste
132567
texto com numero no fim123456
texto222333texto
texto2223334texto`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}