using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(\d{6})(?!\d)";
string input = @"teste 1 n°123456 fim do teste
teste 2 n°7890123 fim do teste
132567
texto com numero no fim123456
texto222333texto
texto2223334texto";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}