using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?;(.*?);.*";
string substitution = @"$1";
string input = @"1943;1943: The Battle of Midway (Euro);Final Burn Alpha;;1987;Capcom;Shooter / Flying Vertical;2P sim;270;joystick (8-way);good;1;raster;;;;2";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}