// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*?;(.*?);.*").unwrap();
let string = "1943;1943: The Battle of Midway (Euro);Final Burn Alpha;;1987;Capcom;Shooter / Flying Vertical;2P sim;270;joystick (8-way);good;1;raster;;;;2";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}