#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<h\d.*?(?=<h\d)"
Local $sString = "" & @CRLF & _
" <!-- wp:heading -->" & @CRLF & _
"<h2>header 1</h2>" & @CRLF & _
"<!-- /wp:heading -->" & @CRLF & _
"" & @CRLF & _
"<!-- wp:paragraph -->" & @CRLF & _
"<p>Text text 1</p>" & @CRLF & _
"<!-- /wp:paragraph -->" & @CRLF & _
"" & @CRLF & _
"<!-- wp:heading -->" & @CRLF & _
"<h2>header 2</h2>" & @CRLF & _
"<!-- /wp:heading -->" & @CRLF & _
"" & @CRLF & _
"<!-- wp:paragraph -->" & @CRLF & _
"<p>Text text 2</p>" & @CRLF & _
"<!-- /wp:paragraph -->" & @CRLF & _
"" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")